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In Depth: Writer

The word processor is arguably the most popular element within any office suite. That 

said, you’ll be happy to know that OpenOffice.org’s Writer component doesn’t skimp on 

features. It offers full text-editing and formatting functionality, along with powerful 

higher-level features such as mail merge.

In this chapter, we’ll take a look at some of Writer’s most useful features. As with all of 

the components in the OpenOffice.org suite, describing the features within Writer could 

easily fill an entire book. You should do some exploring on your own by clicking around to 

discover new features, as well as make judicious use of the help system. To start Writer, 

click Applications ➤ Office ➤ OpenOffice.org Word Processor.

Formatting Text
You can format text within Writer using several methods. Here, we’ll look at using the 

Formatting toolbar, the context menu, and the Style and Formatting palette.

The Formatting Toolbar

Formatting text is easy to do via the Formatting toolbar, which is just above the ruler and 

main document area. Using the toolbar buttons, you can select the type of font you wish 

to use, its point size, and its style (normal, bold, italics, and so on). The range of fonts is 

previewed in the Font drop-down list, making it easy to select the right typeface.

In addition, the Formatting toolbar lets you justify text so that it’s aligned to the left or 

right margin, centered, or fully justified. You can also indent text using the relevant icons. 

As with elsewhere in Ubuntu, a tooltip will appear over each icon when you hover the 

mouse cursor over it, as shown in Figure 23-1. To the right of the indentation buttons are 

tools to change the text background and foreground colors, and also a tool to create high-

lighter pen-style effects.
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Figure 23-1. When you hover your mouse over an icon, a tooltip appears to explain what it does.

Context Menu

Rather than use the Formatting toolbar, you can format text using the context menu. 

Right-click the text you want to format, and a context menu will present options for the 

font, size, style, alignment, and line spacing. The context menu also allows you to change 

the case of the highlighted characters—from uppercase to lowercase, and vice versa.

By selecting the Character option from the context menu, you get ultimate control over 

the font formatting. This will present a dialog box that includes every possible option, such as 

rotating the text and altering the individual character spacing (look under the Position tab 

for these options).

■Tip  The Character dialog box lets you create interesting typographical effects. The Paragraph dialog box 

has many options for formatting paragraphs. These tools open up the possibility of using Writer for simple 

desktop publishing work.

Selecting Paragraph from the context menu displays the Paragraph dialog box, as 

shown in Figure 23-2. This gives you control over paragraph elements, such as line spacing, 

indentation, and automatic numbering. Here, you will also find an option to automatically 

create drop caps, so you can start a piece of writing in style!
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Figure 23-2. Writer includes many elements found in desktop publishing packages, such as 

the ability to create drop caps.

The Style and Formatting Palette

The Style and Formatting palette offers a variety of predefined formatting styles that you 

can apply to selected text or enable before you begin adding text. To make it appear, click 

Formatting ➤ Styles and Formatting, or press F11. You can simply click the palette’s close 

button to get rid of it.

You can easily add your own text styles to the Style and Formatting palette. Simply 

select some text that has the formatting applied, click the top-right button (denoted by a 

paragraph symbol next to a block of text), and then select New Style from Selection in the 

list. You’ll be invited to give the style a name, and when you click OK, it will appear in the list.

Spell-Checking
Writer is able to automatically spell-check as you type. Any words it considers misspelled 

will be underlined in red. You can choose from a list of possible corrections by right-clicking 

the word and selecting from the context menu. If you’re sure the word is spelled correctly 

but it doesn’t appear to be in the dictionary, you can select Add ➤ Standard.dic from the 

context menu, as shown in Figure 23-3. This will add the word to your own personal 

dictionary extension (other users won’t have access to your dictionary and will need to 

create their own list of approved words).
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Figure 23-3. Any words you’re going to use frequently, but which Writer doesn’t recognize, can 

be added to your personal dictionary.

■Tip  You might find that the spell-checker is set for US English. If you live outside the United States, or need 

to create documents for readers in other countries, you can choose a dictionary tailored to your locality or 

needs. To change the language, select Tools ➤ Options. In the list on the left, select Language Settings, and 

then Languages. In the Default Languages for Documents list, select your local variation. This will then become 

the default for all new documents.

If you find live spell-checking invasive or distracting, you can deactivate it by selecting 

Tools ➤ Spellcheck, clicking the Options button, and removing the check next to Check 

Spelling As You Type.

You can manually spell-check the document at any time by clicking Tools ➤ Spellcheck. 

This will scan through the document and prompt you for corrections for words the 

program considers misspelled.
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Inserting Pictures
Writer includes quite substantial desktop publishing–like functions, such as the ability to 

insert pictures into text documents and to have text flow around pictures.

Inserting any kind of graphic—a graph, digital camera photo, drawing, or any other 

type of image—is easy. Simply choose Insert ➤ Picture ➤ From File.

■Tip  If you have a scanner, you can also scan pictures directly into Writer documents. Simply click Insert ➤ 

Picture ➤ Scan ➤ Select Source.

After you’ve inserted a picture, you can place it anywhere on the page. When you select 

the picture, a new toolbar appears. This toolbar contains various simple image-tweaking 

tools, such as those for altering the brightness, contrast, and color balance of the image. 

Additionally, by clicking and dragging the blue handles surrounding the image, you can 

resize it.

Graphics that are imported into Writer must be anchored in some way. In other words, 

they must be linked to a page element so that they don’t move unexpectedly. By default, 

they’re anchored to the nearest paragraph, which means that if that paragraph moves, the 

graphic will move, too. Alternatively, by right-clicking the graphic, you can choose to 

anchor it to the page, paragraph, or character it is on or next to, as shown in Figure 23-4. 

Selecting to anchor it to the page will fix it firmly in place, regardless of what happens to 

the contents of the surrounding text. The As Character option is slightly different from the 

To Character option. When you choose As Character, the image will be anchored to the 

character it is next to, and it is actually inserted in the same line as that character, as if it 

were a character itself. If the image is bigger than the line it is anchored in, the line height 

will automatically change to accommodate it.

Figure 23-4. A picture can be “anchored” to the page, paragraph, or a character. This affects 

how it responds to the paragraphs surrounding it.
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As you can see in Figure 23-4, the context menu also includes a Wrap option, which lets 

you set the type of text wrap you want to use. By default, Optimal Page Wrap is selected. 

This causes the text to wrap down just one side of the picture—the side on which the 

picture is farthest from the edge of the page. Alternatives include No Wrap, which will 

mean that the graphic will occupy the entire space on the page; no text is allowed on either 

side of it. However, Page Wrap is the best option if you’re looking for a desktop publishing–

style effect, because the text will wrap around both sides of the picture. Alternatively, if 

you wish the image to appear in the background of the page with text flowing across it, 

you can select the relevant option from the context menu.

As always within OpenOffice.org, ultimate control is achieved by opening the relevant 

dialog box. You can set up how graphics are treated on the page by right-clicking the 

image and selecting Picture. In the dialog box that appears, you can select the wrap effect, 

specify the invisible border around the wrap (which governs how close the text is to the 

image), and give the image a border frame.

Working with Tables
Often, it’s useful to present columns of numbers or text within a word processor document. 

To make it easy to align the columns, OpenOffice.org offers the Table tool. This lets you 

quickly and easily create a grid in which to enter numbers or other information. You can 

even turn tables into simple spreadsheets, and tally rows or columns via simple formulas.

To insert a table, click and hold the Table icon on the Standard toolbar (which runs 

across the top of the screen beneath the menu). Then simply drag the mouse in the table 

diagram that appears until you have the desired number of rows and columns, and release 

the mouse button to create the table, as shown in Figure 23-5.

Figure 23-5. Just select the Table icon on the Main toolbar and drag the mouse to define the 

size of the table. Release the mouse button when you’re finished.
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Whenever your cursor is inside the table, a new toolbar will appear, offering handy options. 

Once again, simply hover your mouse over each button to find out what it does via a 

tooltip.

As with spreadsheets, tables consist of cells arranged into rows (running horizontally) 

and columns (running vertically). Altering the size of a column is easy. Just hover the 

mouse over the edge of a cell until it changes to a resizing cursor, and then click and drag. 

You can do the same on a horizontal bar to alter a cell’s height, but a far better method is 

to right-click within the cell, select Row ➤ Height, and enter a value. This will ensure that 

subsequent cells are shifted down to make space for the newly enlarged cell, which doesn’t 

happen when you click and drag the cell’s border.

■Tip  An alternative way of resizing cells is to click in a cell and press the Enter key, which inserts a carriage 

return. Cells expand in size to fit their contents.

Once the cursor is within a table, you can move from cell to cell using the Tab key. 

Alternatively, you can move backward through the cells by pressing Shift+Tab.

To add more rows or columns, click the relevant icon on the Table toolbar (the fourth 

and fifth buttons on the bottom row). To split an existing cell, ensure your cursor is inside 

it, right-click, select Cell from the menu, and then click Split.

If you want to total figures within a table, click in an empty cell, and then click the Sum 

icon on the Table toolbar (the Greek sigma symbol on the right side of the bottom row). 

This is similar to inserting a function in a spreadsheet. The cell holds the formula for the 

sum and clicking additional cells, or a range of cells, adds them to the sum.

■Note  Only correctly formatted cells can be summed using the Sum icon on the Table toolbar. Cells with 

spaces or text within them cannot be added to the formula.

You can alter the styling of any cell using various icons on the Table toolbar, as well as 

the standard text formatting tools on the Formatting toolbar. The Table toolbar allows 

you to add borders to the cells and change the background colors. Alternatively, you can 

choose to remove all borders from the cells by clicking the Borders icon and then the No 

Borders option (note that gray borders will remain in place, but these are only for your 

convenience and won’t appear in printouts).
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Mail Merging
Mail merging refers to automatically applying a database of details, such as names and 

addresses, to a document, so that many personalized copies are produced. It’s ordinarily 

used to create form letters for mailings.

OpenOffice.org makes the procedure very easy, but it requires source data that will be 

merged into the document. As with Microsoft Word, you can either enter this data within 

Writer itself or choose to import data from a separate document. Unless you have enough 

knowledge of databases to connect one to OpenOffice.org (the program works with dBase 

and MySQL files, among others), you may want to input existing data in the form of a 

comma-separated value (CSV) text file. This is the simplest form of data file that is under-

stood by the majority of office programs and databases.

Here, we’re going to look at entering the data within Writer, which is the best policy for 

smaller mail merge operations. You can then output the data as a CSV file, so you can use 

it again later. Here are the steps for using mail merge (click the Next button after each step):

1. Select Tools ➤ Mail Merge Wizard to start the wizard, as shown in Figure 23-6.

2. Specify your starting document, which is the document in which the merged data 

will appear. You can opt to use the current document, create a new document, 

open a document from file, or use a template as the basis for your file.

3. Choose the mail merge type. You can choose to create a merged e-mail (for sending 

to multiple recipients) or a merged letter.

4. You’re asked to tell Writer about your data. Writer needs to know where to find the 

addresses that will be merged into the document. Click the Select Address List button.

5. In the window that appears, you have a number of options. You can raid your 

Evolution e-mail address book for the data, click Add to select an already existing 

data source (such as a database or CSV file), or create a data source from scratch. 

Click the Create button to create a data source to enter the data in Writer. 

■Note  The fourth option for choosing a mail merge data source, Filter, allows you to filter the database 

source you select after clicking Add, so that you can import only specific data. To learn more about this 

technique, browse the OpenOffice.org Help file (click Help ➤ OpenOffice.org Help) and search for Filtering ➤ 

Data in Databases.
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Figure 23-6. The Mail Merge Wizard makes creating multiple documents from a data source 

incredibly easy.

6. You’re presented with a form for entering the data for each individual you want to 

receive the mail-merged letter, as shown in Figure 23-7. You don’t need to fill in 

each field; you’ll be able to choose which data fields to use in the document later 

on. If you wish to enter your own specific data types in addition to address details, 

you can click the Customize button to add your own field to the list. Using the up and 

down arrows in the window that appears, position the highlight where you would like 

the data to appear. Then click the Add button (alternatively, if there’s a data field 

you’re not using, you can highlight it and select Rename to reuse it). Obviously, you 

should add any new data fields you want before you begin to enter data!

7. Type in the data and press Enter at the end of each line. When you get to the last 

field, click the New button at the top right. When you’ve finished entering all the 

data, click OK. Then accept Writer’s offer to save the data as a CSV file.

8. You’re returned to the data-selection screen, and your just-saved file will be in the 

list. Click OK.
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Figure 23-7. Enter the data for each person you want to receive the letter.

9. You’re returned to the main Mail Merge Wizard window, where you can select 

whether or not to include an address block. All this means is that Writer will auto-

matically add the merge fields to your document in what it considers the correct 

format (for example, title, followed by first and last name, with each line of the 

address underneath, and so on). You can insert the merge fields manually later on 

if you wish; in that case, remove the check from the “This document shall contain 

an address block” check box. Click Next.

10. You’re invited to create the salutation that will head the letter. This will contain the 

merge data as well, so that you can personalize the letter. Again, you can accept the 

default, tweak it slightly, or choose not to have an automated salutation (so that 

you can create your own later).

11. Depending on your previous choices, and whether you accepted the automatic 

address block and salutation, you are now given the choice to adjust the layout of 

the document in a rough way or to actually edit it (note that even if you accepted 

the address block and/or salutation, you’ll get a chance to edit the document in the 

next step anyway).
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12. If you opt to edit the document, you can insert your choice of merge fields by clicking 

Insert ➤ Fields ➤ Other. Select the Database tab in the window that appears, and 

then select Mail Merge Fields on the left side of the window. Click the small plus 

symbol next to the data file you created earlier, which should be listed on the right, 

and you can then select and insert the merge fields. Once you’ve finished, click the 

Return to Mail Merge Wizard button.

13. Click Next to perform the merge. You’re then given a chance to edit the actual mail-

merged documents (which, depending on the quantity of data entries you created 

earlier, could number in the tens, hundreds or even thousands!).

14. You can save or print the merged document containing the data. To save the doc-

ument creating the merge fields, click Save Starting Document.

Adding Headers and Footers
You may want to add headers and footers to long documents to aid navigation. They 

appear at the top and bottom of each page, respectively, and can include the document 

title, page number, and other information. Headers and footers are created and edited 

independently of the main document.

As you might expect, inserting both headers and footers takes just a couple of clicks. 

Select Insert ➤ Header ➤ Default or Insert ➤ Footer ➤ Default, depending on which you 

wish to insert (documents can have both, of course). Writer will then display an editing 

area where you can type text to appear in the header or footer. For more options, right-click 

in the area, select Page, and then click the Header or Footer tab. Here, you can control the 

formatting and nature of the header or footer. Clicking the More button will let you apply 

borders or background colors.

You might wish to insert page numbers that will be updated automatically as the docu-

ment progresses. OpenOffice.org refers to data that automatically updates as a field. You 

can insert a wide variety of fields by selecting Insert ➤ Fields, as shown in Figure 23-8. For 

example, along with the page number, you can insert the document title and author name 

(which is read from the details entered into the Options configuration dialog box, accessed 

from the Tools menu). In addition, you can enter mail merge fields by clicking Other (see 

the previous section for a description of how to associate mail merge data with a document).
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Figure 23-8. Automatically updating data, such as page numbers, can be inserted into 

headers and footers.

Summary
In this chapter, we’ve examined Writer, one of the core components of OpenOffice.org. 

We’ve looked at the some of the key tools, which enable quick and easy document creation. In 

particular, you’ve learned how to format text, use the spell-checking component, insert 

pictures, create and edit tables, mail merge, and add headers and footers.

In the next chapter, we move on to another vital part of OpenOffice.org: Calc, the 

spreadsheet component.


